Solved: an error updating certificate : REMOTE_ADDR didn’t parse

Did your freepbx dashboard notified a security certificate error ? ” There was an error updating certificate : REMOTE_ADDR didn’t parse “. Lets see how to resolve this

Basically the error is part of outdated firewall module which comes in sync with certificate renewal using letsncrypt or similar services. The danger of this situation is that, in most cases firewall has got disabled automatically and it leads to huge volume of attack from internet

There was an error updating certificate : REMOTE_ADDR didn't pars

How to sort REMOTE_ADDR didn’t parse error ?

Update the modules, specially the firewall module. But it is recommended to do all to avoid any module compatibility errors. Update the pbx modules using the Module admin in Graphical interface or using SSH . SSH is best as it is very secure and doesn’t get disconnected during an update. You will also be notified of Linux upgrades while accessing via SSH.

Commands for upgrade using SSH

fwconsole ma updateall
fwconsole ma upgradeall

for older versions

amportal a ma updateall

Reboot the system once the update it finished.

Make sure Firewall is turned ON

Navigate to Connectivity -> Firewall and make sure the responsive firewall is turned on for the services open to public. This should resolve the specified error and secure back your pbx.

Final note: Restart again after the certificate update

The certificate will update by itself. In most cases, certificate update also will happen just after the update . If this happens after the restart , you will see an notification for restart.

Let us know you valuable opinion to improve our articles and service. Looking forward to hear from you!

Now its your turn ! Let us know what is in your mind